Email Delivery Delays

Incident Report for GSVT Services

Resolved

Our email provider has confirmed this issue is resolved.
Posted Jul 19, 2024 - 20:17 UTC

Monitoring

Our upstream provider has indicated that a fix is now in place and email systems are working. We are monitoring for any further issues and awaiting final confirmation from the provider that the issue is completely fixed.
Posted Jul 19, 2024 - 17:43 UTC

Identified

Our upstream email provider has reported that they are experiencing some delays with sending emails. This may impact the timely delivery of all alerts, call log email messages, and all other sources of email that would be generated automatically by our systems. Our upstream provider is tracking the issue here: https://status.sendgrid.com/incidents/zc5xr3n3bf54

We will provide updates as our email provider works on the issue.
Posted Jul 19, 2024 - 17:09 UTC
This incident affected: Client-Facing (Site Generator, V2 Websites, GSVT Messaging System).