Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 26, 2026 - 19:00 UTC
Scheduled
The Alerts application is scheduled to have maintenance on March 26th at 3:00 PM EST for about 15 minutes. During this time, some systems may not be fully operational and there will be a brief interruption in alert delivery. Please open a ticket on the service desk if you have any questions or concerns about the affected systems.
Posted Mar 19, 2026 - 16:51 UTC
This scheduled maintenance affected: Client-Facing (Alerts).